cpt

[ARCHIVED] Carbs Packaging Tools
git clone git://git.ckyln.com/~cem/cpt.git
Log | Files | Refs | README | LICENSE

commit fe7cc390260d17c6f7e7d97d78efb289de68f287
parent 42b71ab2df0b6205d7ef0b287eefe04e59d3e687
Author: black <dylan.araps@gmail.com>
Date:   Sun, 15 Sep 2019 10:51:26 +0300

Merge pull request #55 from kisslinux/lax_deps

Lax deps
Diffstat:
Mkiss | 11+++++------
1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/kiss b/kiss @@ -345,7 +345,7 @@ pkg_build() { log "Resolving dependencies" - for pkg; do + for pkg; do contains "$explicit" "$pkg" || { pkg_depends "$pkg" explicit @@ -361,14 +361,13 @@ pkg_build() { # package, remove it from the explicit list as it needs to be # installed as a dependency. for pkg; do - # There's no better way to remove a word from a string in + # There's no better way to remove a word from a string in # POSIX 'sh' sadly. - contains "$deps" "$pkg" && + contains "$deps" "$pkg" && explicit=$(echo "$explicit" | sed "s/ $pkg / /g") done set -- $deps $explicit - log "Building: $*" # Only ask for confirmation if more than one package needs to be built. @@ -387,7 +386,7 @@ pkg_build() { # Install any pre-built dependencies if they exist in the binary # directory and are up to date. for pkg; do - # Don't check for a pre-built package if it was passed + # Don't check for a pre-built package if it was passed # to KISS directly. contains "$explicit_build" "$pkg" || { # Figure out the version and release. @@ -950,7 +949,7 @@ args() { ;; v|version|-v|--version) - printf 'kiss 0.22.0\n' + printf 'kiss 0.30.0\n' ;; h|help|-h|--help|'')